• 欢迎访问明阳程序化网,通达信指标公式讲解、公式编写、形态选股、策略预警等。永久网址cxh110.com明阳程序化

【通达信】MACD与KDJ多周期共振副图指标公式

转载公式 admin 9个月前 (03-11) 已收录
文章目录[隐藏]

【通达信】MACD与KDJ多周期共振副图指标公式


公式源码:

 DIF60:=EMA(CLOSE,12/2)-EMA(CLOSE,26/2);
DEA60:=EMA(DIF60,9/2);
STICKLINE(DIF60>=DEA60,42,46,5,0),COLOR00BBBB;
STICKLINE(DIF60<DEA60,42,46,5,1),COLOR696969;
DRAWTEXT(CURRBARSCOUNT=13,44,'★60分钟MACD★'),COLORWHITE;
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
STICKLINE(DIF>=DEA,36,40,5,0),COLOR0000BB;
STICKLINE(DIF<DEA,36,40,5,1),COLOR696969;
DRAWTEXT(CURRBARSCOUNT=13,38,'★MACD日线★'),COLOR00FFFF;
周MD:=MACD.DIF#WEEK;
周MA:=MACD.DEA#WEEK;
STICKLINE(周MD>=周MA,30,34,5,0),COLORBB00BB;
STICKLINE(周MD<周MA,30,34,5,1),COLOR696969;
DRAWTEXT(CURRBARSCOUNT=13,32,'★MACD周线★'),COLOR00FFFF;
月MD:=MACD.DIF#MONTH;
月MA:=MACD.DEA#MONTH;
STICKLINE(月MD>=月MA,24,28,5,0),COLORBBBB00;
STICKLINE(月MD<月MA,24,28,5,1),COLOR696969;
DRAWTEXT(CURRBARSCOUNT=13,26,'★月MACD★'),COLORWHITE;
RSV60:=(CLOSE-LLV(LOW,36))/(HHV(HIGH,36)-LLV(LOW,36));
K60:=SMA(RSV60,3,1);
D60:=SMA(K60,3,1);
STICKLINE(K60>= D60,18,22,5,0),COLOR00FFFF;
STICKLINE(K60 < D60,18,22,5,1),COLOR696969;
DRAWTEXT(CURRBARSCOUNT=13,20,'★60分钟KDJ★ '),COLORFF00FF;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9));
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
STICKLINE(K>=D,12,16,5,0),COLOR0000FF;
STICKLINE(K<D,12,16,5,1),COLOR696969;
DRAWTEXT(CURRBARSCOUNT=13,14,'★KDJ日线★'),COLORFFFFFF;
周K:="KDJ.K#WEEK" ;
周D:="KDJ.D#WEEK" ;
STICKLINE(周K>=周D,6,10,5,0),COLORFF00FF;
STICKLINE(周K<周D,6,10,5,1),COLOR696969;
DRAWTEXT(CURRBARSCOUNT=13,8,'★KDJ周线★'),COLORWHITE;
月K:="KDJ.K#MONTH" ;
月D:="KDJ.D#MONTH" ;
STICKLINE(月K>=月D,0,4,5,0),COLORFF00FF;
STICKLINE(月K<月D,0,4,5,1),COLOR696969;
DRAWTEXT(CURRBARSCOUNT=13,2,'★KDJ月线★'),COLORWHITE;
DRAWTEXT_FIX(C>O,0.85,0.001,0,'明阳程序化CXH110.COM'),COLORFF7F00;

明阳程序化 , 版权所有丨如未注明 , 均为原创丨为支持本站发展,也可以支付宝捐赠,谢谢!
转载请注明原文链接:【通达信】MACD与KDJ多周期共振副图指标公式
喜欢 (0)
[明阳程序化]
分享 (0)