• 欢迎访问明阳程序化网,通达信指标公式讲解、公式编写、形态选股、策略预警等。永久网址cxh110.com明阳程序化

【通达信】做多做空副图指标公式

转载公式 admin 6个月前 (05-04) 已收录
文章目录[隐藏]

【通达信】做多做空副图指标公式


公式源码:

 A:EMA((CLOSE-REF(C,1))/REF(C,1)*10-
(INDEXC-REF(INDEXC,1))/REF(INDEXC,1)*10,5),COLORRED;
STICKLINE(A>0,0,A,1,2),LINETHICK1,COLORRED;
STICKLINE(A<0,0,A,1,2),LINETHICK2,COLORGREEN;
HSNP1:=CLOSE-REF(CLOSE,1);
HSNP2:=IF(CLOSE-REF(CLOSE,1)>=0,HSNP1,0);
HSNP3:=REF(CLOSE,1)-CLOSE;
HSNP4:=IF(CLOSE-REF(CLOSE,1)<=0,HSNP3,0);
HSNP5:=SUM(HSNP2,90)/SUM(HSNP4,90);
HSNP6:=100-100/(1+HSNP5);
HSNP7:=EMA(HSNP6,21);
HSNP8:=EMA(HSNP7,5);
HSNP:=EMA(HSNP7,3);
NP:= (HSNP7-HSNP),,LINETHICK1;
NL:=(HSNP-HSNP7),COLORYELLOW,LINETHICK1;
STICKLINE(NL<0,0,NL,1,2),COLOR0B0B77;
STICKLINE(NP<0,0,NP,1,2),COLOR666666;
JJ :=(C*2+H+L)/4;
SK := EMA(JJ,13) - EMA(JJ,21);
SD := EMA(SK,3);
SP := EMA(SK,10);
长线1:IF(SD>=SP,SD,SP),LINETHICK2,;
长线2:IF(SP-SD,SP,SD),LINETHICK2,COLORWHITE;
A1:=EMA(CLOSE,7)-EMA(CLOSE,21);
B1:=EMA((0.668*REF(A1,1)+0.333*A1),1);
做多:IF(A1>=B1,A1,B1),LINETHICK2,COLORRED;
做空:IF(B1-A1,B1,A1),LINETHICK2,COLORGREEN;
DRAWTEXT_FIX(C>O,0.85,0.001,0,'明阳程序化CXH110.COM'),COLORFF7F00;

明阳程序化 , 版权所有丨如未注明 , 均为原创丨为支持本站发展,也可以支付宝捐赠,谢谢!
转载请注明原文链接:【通达信】做多做空副图指标公式
喜欢 (0)
[明阳程序化]
分享 (0)