• 欢迎访问明阳程序化网,通达信指标公式讲解、公式编写、形态选股、策略预警等。永久网址cxh110.com明阳程序化

【通达信】量能MACD副图指标公式

转载公式 admin 7个月前 (05-07) 已收录
文章目录[隐藏]

【通达信】量能MACD副图指标公式


公式源码:

 DIF:=EMA((SMA(AMOUNT,5,1)/100000000)*V/(MA(REF(V,1),3)),6) - EMA((SMA(AMOUNT,10,1)/100000000)*V/(MA(REF(V,1),3)),34),DOTLINE;
DEA:=EMA(DIF,5),DOTLINE,COLORFF1010;
MACD:=(DIF-DEA)*12, COLORSTICK;
W1:STICKLINE(MACD>0,MACD,0,3,-1),COLORRED;
W2:STICKLINE(MACD<0,MACD,0,3,-1),COLORCYAN;
YD:STICKLINE(MACD>REF(MACD,1)AND C>REF(C,1)AND MACD<0 ,MACD,0,2.2,0)COLOR00EEEE;
TJ:=DEA>DIF;T:=DIF>=DEA;
A:=HHV(MACD,+5)=MACD;
B:=LLV(MACD,+5)=MACD;
CW:=LLV(MACD,+55)=MACD;
选择A:DRAWICON(A AND FILTERX(A,6),MACD,13);
选择B:DRAWICON(B AND FILTERX(B,6),MACD,14);
斐文A: DRAWTEXT(BARSLAST(TJ)=1,MACD,'1'),COLORYELLOW;
斐文1A: DRAWTEXT(BARSLAST(TJ)=2,MACD,'2'),COLORYELLOW;
斐文2A: DRAWTEXT(BARSLAST(TJ)=3,MACD,'3'),COLORYELLOW;
斐文3A: DRAWTEXT(BARSLAST(TJ)=5,MACD,'5'),COLORYELLOW;
斐文4A: DRAWTEXT(BARSLAST(TJ)=8,MACD,'8'),COLORYELLOW;
斐文5A: DRAWTEXT(BARSLAST(TJ)=13,MACD,'13'),COLORYELLOW;
斐文6A: DRAWTEXT(BARSLAST(TJ)=21,MACD,'21'),COLORYELLOW;
斐文7A: DRAWTEXT(BARSLAST(TJ)=34,MACD,'34'),COLORYELLOW;
斐文8A: DRAWTEXT(BARSLAST(TJ)=55,MACD,'55'),COLORYELLOW;
斐文8A1: DRAWTEXT(BARSLAST(TJ)=55,MACD,'55'),COLORYELLOW;
斐文8A2: DRAWTEXT(BARSLAST(TJ)=89,MACD,'89'),COLORYELLOW;
斐文8A3: DRAWTEXT(BARSLAST(TJ)=144,MACD,'144'),COLORYELLOW;
斐文8A4: DRAWTEXT(BARSLAST(TJ)=233,MACD,'233'),COLORYELLOW;
斐文8A5: DRAWTEXT(BARSLAST(TJ)=377,MACD,'377'),COLORYELLOW;
斐文9A: DRAWTEXT(BARSLAST(T)=1,MACD,'1'),COLORGREEN;
斐文0A: DRAWTEXT(BARSLAST(T)=2,MACD,'2'),COLORGREEN;
斐文11A: DRAWTEXT(BARSLAST(T)=3,MACD,'3'),COLORGREEN;
斐文12A: DRAWTEXT(BARSLAST(T)=5,MACD,'5'),COLORGREEN;
斐文13A: DRAWTEXT(BARSLAST(T)=8,MACD,'8'),COLORGREEN;
斐文14A: DRAWTEXT(BARSLAST(T)=13,MACD,'13'),COLORGREEN;
斐文15A: DRAWTEXT(BARSLAST(T)=21,MACD,'21'),COLORGREEN;
斐文16A: DRAWTEXT(BARSLAST(T)=34,MACD,'34'),COLORGREEN;
斐文17A: DRAWTEXT(BARSLAST(T)=55,MACD,'55'),COLORGREEN;
DRAWTEXT_FIX(C>O,0.85,0.001,0,'明阳程序化CXH110.COM'),COLORFF7F00;

明阳程序化 , 版权所有丨如未注明 , 均为原创丨为支持本站发展,也可以支付宝捐赠,谢谢!
转载请注明原文链接:【通达信】量能MACD副图指标公式
喜欢 (0)
[明阳程序化]
分享 (0)