• 欢迎访问明阳程序化网,通达信指标公式讲解、公式编写、形态选股、策略预警等。永久网址cxh110.com明阳程序化

【通达信】探底防线副图指标公式

转载公式 admin 5个月前 (05-07) 已收录
文章目录[隐藏]

【通达信】探底防线副图指标公式


公式源码:

 VAR1:=(HHV(HIGH,9)-LLV(LOW,9));
VAR2:=(HHV(HIGH,9)-CLOSE);
VAR3:=(CLOSE-LLV(LOW,9));
VAR4:=VAR2/VAR1*100-70 ;
VAR5:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
VAR6:=(2*C+H+L)/4;
VAR7:=SMA((VAR3/VAR1*100),3,1);
VAR8:=LLV(LOW,34);
VAR9:=SMA(VAR7,3,1)-SMA(VAR4,9,1);
VAR10:= IF(VAR9>100,VAR9-100,0);
VARA:=HHV(HIGH,34);
AA:=VAR10*2, COLORFFCCCC;
R1:=(HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9))*100-70;
R2:=SMA(R1,9,1)+100;
R3:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
R4:=SMA(R3,3,1);
R5:=SMA(R4,3,1)+100;
R6:=R5-R2;
防线A:IF(R6>55,R6-55,0);
SMA(防线A,2,1),COLORFF00FF;
防线B:EMA((VAR6-VAR8)/(VARA-VAR8)*100,13),COLORFFCC66;
B1:=EMA(0.667*REF(防线B,1)+0.333*防线B,2);
B1,COLORRED;
防线C:SMA(VAR5,20,1),COLORBLUE;
SMA(防线C,5,1),COLORBLUE;
A:=SMA(AA,2,1)-AA;
B:=EMA(0.667*REF(防线B,1)+0.333*防线B,2)-防线B;
S:EMA(0.382*REF(防线B,2)+0.618*防线B,12),COLORYELLOW;
STICKLINE(REF(防线A,1)<防线A,防线A,REF(防线A,1),5,0),COLORYELLOW;
STICKLINE(REF(防线A,1)>防线A,防线A,REF(防线A,1),5,0),COLORFF00FF;
STICKLINE(防线B-B1>0,防线B,B1,5,0),COLORRED;
STICKLINE(防线B-B1<0,防线B,B1,5,0),COLORFFCC66;
STICKLINE(防线C-SMA(防线C,5,1)>0,防线C,SMA(防线C,5,1),5,0),COLORWHITE;
STICKLINE(防线C-SMA(防线C,5,1)<0,防线C,SMA(防线C,5,1),5,0),COLORBLUE;
DRAWTEXT_FIX(C>O,0.85,0.001,0,'明阳程序化CXH110.COM'),COLORFF7F00;

明阳程序化 , 版权所有丨如未注明 , 均为原创丨为支持本站发展,也可以支付宝捐赠,谢谢!
转载请注明原文链接:【通达信】探底防线副图指标公式
喜欢 (0)
[明阳程序化]
分享 (0)