• 欢迎访问明阳程序化网,通达信指标公式讲解、公式编写、形态选股、策略预警等。永久网址cxh110.com明阳程序化

【通达信】上下体涨跌主图指标公式

转载公式 admin 5个月前 (05-07) 已收录
文章目录[隐藏]

【通达信】上下体涨跌主图指标公式


公式源码:

 N:=14;
K:=N/2;
MAK:MA(CLOSE,K),COLORWHITE,LINETHICK1;
MAN:MA(CLOSE,N),COLORRED,LINETHICK1;
DTPL:=MA(C,N)>MA(C,N*1.5) AND MA(C,N*1.5)>MA(C,N*3) AND MA(C,3)>MA(C,N*6);
选择均线:=N;
强弱天数:=K;
连续走强:=COUNT(C>MA(C,N),K)=K;
ZQSJ:=BARSLAST(连续走强);
下穿:=CROSS(MA(C,N),C);
GL:=MA(C,N/2)/MA(C,N*2)>=1.05;
下体泄:=(下穿 AND ZQSJ<=3 AND DTPL AND GL)*N;
连续走弱:=COUNT(C<MA(C,N),K)=K;
ZRSJ:=BARSLAST(连续走弱);
上穿:=CROSS(C,MA(C,N));
下体涨:=(上穿 AND ZRSJ<=3)*K;
DRAWTEXT(下体涨>0 ,L*0.99 , '买点'),COLORYELLOW,LINETHICK1;
STICKLINE(下体涨>0,H,L,0,1),COLORF00FF0,LINETHICK2;
STICKLINE(下体涨>0,O,C,6,1),COLORF00FF0,LINETHICK2;
DRAWTEXT(下体泄>0 ,L*0.99 , '买跌'),COLOR00FF00,LINETHICK1;
STICKLINE(下体泄>0 ,H,L,0,1),COLOR00FF00,LINETHICK2;
STICKLINE(下体泄>0 ,O,C,6,1),COLOR00FF00,LINETHICK2;
DRAWTEXT(连续走强>0 ,MAN-0.01 , ''),COLORYELLOW,LINETHICK1;
DRAWTEXT(连续走弱>0 ,MAK-0.01 , ''),COLOR00FF00,LINETHICK1;
DRAWTEXT_FIX(C>O,0.85,0.001,0,'明阳程序化CXH110.COM'),COLORFF7F00;

明阳程序化 , 版权所有丨如未注明 , 均为原创丨为支持本站发展,也可以支付宝捐赠,谢谢!
转载请注明原文链接:【通达信】上下体涨跌主图指标公式
喜欢 (0)
[明阳程序化]
分享 (0)