• 欢迎访问明阳程序化网,通达信指标公式讲解、公式编写、形态选股、策略预警等。永久网址cxh110.com明阳程序化

【通达信】买进加码主图指标公式

转载公式 admin 5个月前 (05-07) 已收录
文章目录[隐藏]

【通达信】买进加码主图指标公式


公式源码:

 MA3:MA(C,3),COLORWHITE;
MA5:MA(C,5),COLORGREEN;
MA10:MA(C,10),COLORRED;
MA20:MA(C,20),COLORBLUE;
MA30:MA(C,30),COLORYELLOW;
VAR1:=EMA(C,3);
VAR2:=EMA(C,5);
VAR3:=EMA(C,10);
VAR4:=EMA(C,20);
VAR5:=EMA(C,30);
VAR6:=(VAR2+VAR3+VAR4+VAR5)/4;
VAR7:=(VAR6-REF(VAR6,15))/REF(VAR6,15)*100;
VAR8:=(VAR6-REF(VAR6,15))/REF(VAR6, 15)*100;
VAR9:=EMA(VAR7,8);
STICKLINE(VAR7<1*REF(VAR7,1),H,L,0.5,0),COLORBLUE;
STICKLINE(VAR7<1*REF(VAR7,1),O,C,2, 0),COLORBLUE;
STICKLINE(VAR7>1*REF(VAR7,1),H,L,0.5,0),COLORRED;
STICKLINE(VAR7>1*REF(VAR7,1),O,C,2, 0),COLORRED;
STICKLINE(VAR7<1*REF(VAR7,1) AND VAR9>1*REF(VAR9,1),H,L,0.5,0),COLORGREEN;
STICKLINE(VAR7<1*REF(VAR7,1) AND VAR9>1*REF(VAR9,1),O,C,2, 0),COLORGREEN;
买进价:=((C-REF(MA(C,6),1))/6+MA(C,6))*1.004;
买进条件:=CROSS(C,买进价) AND 买进价>REF(买进价,1);
DRAWTEXT(买进条件,L-0.02,'买'),COLORWHITE,LINETHICK2;
STICKLINE(买进条件,H,L,0,1),COLORWHITE,LINETHICK2;
STICKLINE(买进条件,O,C,2,0),COLORWHITE,LINETHICK2;
加码价:=((C-REF(MA(C,18),1))/18+MA(C,18))*1.004;
加码条件:=CROSS(C,加码价) AND 加码价>REF(加码价,1);
DRAWTEXT(加码条件,L-0.02,'加码'),COLORYELLOW,LINETHICK2;
;
STICKLINE(加码条件,O,C,2,0),COLORYELLOW,LINETHICK2;
DRAWTEXT_FIX(C>O,0.85,0.001,0,'明阳程序化CXH110.COM'),COLORFF7F00;

明阳程序化 , 版权所有丨如未注明 , 均为原创丨为支持本站发展,也可以支付宝捐赠,谢谢!
转载请注明原文链接:【通达信】买进加码主图指标公式
喜欢 (0)
[明阳程序化]
分享 (0)