• 欢迎访问明阳程序化网,通达信指标公式讲解、公式编写、形态选股、策略预警等。永久网址cxh110.com明阳程序化

【通达信】多日涨跌幅副图指标公式

转载公式 admin 5个月前 (05-08) 已收录
文章目录[隐藏]

【通达信】多日涨跌幅副图指标公式


公式源码:

 M:=120;
N:=20;
五日涨跌幅:IF(TOTALBARSCOUNT>=M AND DYNAINFO(4)>0 AND COUNT(COUNT((DATETODAY(DATE)-REF(DATETODAY(DATE),1))>10,BARSLASTCOUNT((C=H AND C>REF(C,1)*1.098) OR (C=L AND C<REF(C,1)*0.902))),5)=0,IF(C>REF(C,5),(C/LLV(C,6)-1),(C/HHV(C,6)-1))*100,0);
十日涨跌幅:IF(TOTALBARSCOUNT>=M AND DYNAINFO(4)>0 AND COUNT(COUNT((DATETODAY(DATE)-REF(DATETODAY(DATE),1))>10,BARSLASTCOUNT((C=H AND C>REF(C,1)*1.098) OR (C=L AND C<REF(C,1)*0.902))),10)=0,IF(C>REF(C,10),(C/LLV(C,11)-1),(C/HHV(C,11)-1))*100,0);
N日涨跌幅:IF(TOTALBARSCOUNT>=M AND DYNAINFO(4)>0 AND COUNT(COUNT((DATETODAY(DATE)-REF(DATETODAY(DATE),1))>10,BARSLASTCOUNT((C=H AND C>REF(C,1)*1.098) OR (C=L AND C<REF(C,1)*0.902))),N)=0,IF(C>REF(C,N),(C/LLV(C,N+1)-1),(C/HHV(C,N+1)-1))*100,0);
DRAWTEXT_FIX(C>O,0.85,0.001,0,'明阳程序化CXH110.COM'),COLORFF7F00;

明阳程序化 , 版权所有丨如未注明 , 均为原创丨为支持本站发展,也可以支付宝捐赠,谢谢!
转载请注明原文链接:【通达信】多日涨跌幅副图指标公式
喜欢 (0)
[明阳程序化]
分享 (0)