• 欢迎访问明阳程序化网,通达信指标公式讲解、公式编写、形态选股、策略预警等。永久网址cxh110.com明阳程序化

【通达信】黑风口夺命山副图指标公式

转载公式 admin 5个月前 (05-10) 已收录
文章目录[隐藏]

【通达信】黑风口夺命山副图指标公式


公式源码:

 Var1:=EMA(CLOSE,2)-EMA(CLOSE,89);
VAR2:=EMA(Var1,30);
VAR3:=2*(Var1-VAR2)*10;
VAR4:=POW(VAR3,3)*0.1+POW(VAR3,2);
黑风口:=IF(VAR3>0.015,VAR4,0)/45;
STICKLINE(黑风口>0 AND 黑风口<=100,0,2+黑风口*0.05,3,1 ),COLOR00BBff;
STICKLINE(黑风口>100 AND 黑风口<=200,0,7+黑风口*0.05,3,1 ),COLOR00BBff;
STICKLINE(黑风口>200 AND 黑风口<=300,0,17+黑风口*0.05,3,1 ),COLOR00BBff;
STICKLINE(黑风口>300 AND 黑风口<=400,0,32+黑风口*0.05,3,1 ),COLOR00BBff;
STICKLINE(黑风口>400 AND 黑风口<=500,0,52+黑风口*0.05,3,1 ),COLOR00BBff;
STICKLINE(黑风口>500 AND 黑风口<=600,0,77+黑风口*0.04,3,1 ),COLOR00BBff;
STICKLINE(黑风口>600 AND 黑风口/10000000<90,0,10+(黑风口/10000000),3,1 ),colorred;
STICKLINE((黑风口/10000000)>90,0,100,2,1 ),colorred;
VAR6:=EMA(CLOSE,2)-EMA(CLOSE,150);
VAR7:=EMA(VAR6,100);
VAR8:=2*(VAR6-VAR7);
VAR9:=POW(VAR8,3)*0.1+POW(VAR8,1);
夺命山:=IF( VAR8>0.05,VAR9,0)*5;
STICKLINE(夺命山>0 AND 夺命山<=100,0,2+夺命山*0.05,3,1 ),COLOR00BBff;
STICKLINE(夺命山>100 AND 夺命山<=200,0,7+夺命山*0.05,3,1 ),COLOR00BBff;
STICKLINE(夺命山>200 AND 夺命山<=300,0,17+夺命山*0.05,3,1 ),COLOR00BBff;
STICKLINE(夺命山>300 AND 夺命山<=400,0,32+夺命山*0.05,3,1 ),COLOR00BBff;
STICKLINE(夺命山>400 AND 夺命山<=500,0,52+夺命山*0.05,3,1 ),COLOR00BBff;
STICKLINE(夺命山>600 AND 夺命山/10000000<90,0,10+(夺命山/10000000),3,1 ),colorred;
STICKLINE((夺命山/10000000)>90,0,100,2,1 ),colorred;
DRAWTEXT_FIX(C>O,0.85,0.001,0,'明阳程序化CXH110.COM'),COLORFF7F00;

明阳程序化 , 版权所有丨如未注明 , 均为原创丨为支持本站发展,也可以支付宝捐赠,谢谢!
转载请注明原文链接:【通达信】黑风口夺命山副图指标公式
喜欢 (0)
[明阳程序化]
分享 (0)