• 欢迎访问明阳程序化网,通达信指标公式讲解、公式编写、形态选股、策略预警等。永久网址cxh110.com明阳程序化

【通达信】安全与风险区副图指标公式

转载公式 admin 5个月前 (05-10) 已收录
文章目录[隐藏]

【通达信】安全与风险区副图指标公式


公式源码:

 CS:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;
YJD: (EMA(CS,3)-50)*2;
YJD,COLORSTICK;
YJF:MA(YJD,5),COLORYELLOW;
VAR18:=(HIGH+LOW+CLOSE)/3;
VAR19:=(VAR18-MA(VAR18,14))/(0.015*AVEDEV(VAR18,14));
VAR1A:=(VAR18-MA(VAR18,70))/(0.015*AVEDEV(VAR18,70));
VAR1B:=IF(VAR19>=150 AND VAR19<200 AND VAR1A>=150 AND VAR1A<200,-10,0);
VAR1C:=IF(VAR19<=-150 AND VAR19>-200 AND VAR1A<=-150 AND VAR1A>-200,10,0);
VAR1D:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
VAR1E:=100-ABS(VAR1D);
风险2:IF(BARSCOUNT(CLOSE)<13,60,IF(VAR1E<88 AND VAR1D>0,40,60)),COLORCCFFCC,LINETHICK2;
出击2:IF(BARSCOUNT(CLOSE)<13,-60,0-IF(VAR1E<92 AND VAR1D<0,40,60)),COLORF00FF0,LINETHICK2;
风险1:IF(BARSCOUNT(CLOSE)<70,80,IF(VAR1A>=200 AND VAR19>=150,-15,VAR1B)+80),LINETHICK2,COLORCCFF66;
出击1:IF(BARSCOUNT(CLOSE)<70,-80,IF(VAR1A<=-200 AND VAR19<=-150,15,VAR1C)-80),COLORRED,LINETHICK2,;
DRAWTEXT(ISLASTBAR,-80,' 高安全区'),COLORWHITE;
DRAWTEXT(ISLASTBAR,-60,' 安全区'),COLORWHITE;
DRAWTEXT(ISLASTBAR,60,' 风险区'),COLORWHITE;
DRAWTEXT(ISLASTBAR,80,' 高风险区'),COLORWHITE;
DRAWTEXT_FIX(C>O,0.85,0.001,0,'明阳程序化CXH110.COM'),COLORFF7F00;

明阳程序化 , 版权所有丨如未注明 , 均为原创丨为支持本站发展,也可以支付宝捐赠,谢谢!
转载请注明原文链接:【通达信】安全与风险区副图指标公式
喜欢 (0)
[明阳程序化]
分享 (0)