• 欢迎访问明阳程序化网,通达信指标公式讲解、公式编写、形态选股、策略预警等。永久网址cxh110.com明阳程序化

【通达信】大小三叉口环主图指标公式

转载公式 admin 7个月前 (05-10) 已收录
文章目录[隐藏]

【通达信】大小三叉口环主图指标公式


公式源码:

 ma13:ma(c,13),colorwhite,linethick2;
ma55:ma(c,55),colorffcc66;
sa0:=MA(CLOSE,3);
sa1:=(h+l+c)/3;
sa2:=hhv(sa1,15);
sa3:=llv(sa1,5);
sa4:=sa2-sa3;
sa5:=ma((sa1-sa3)/sa4,2)*100;
sa6:=hhv(sa1,4*15);
sa7:=llv(sa1,4*15);
sa8:=sa6-sa7;
sa9:=ma((sa1-sa7)/sa8,2)*100;
saA:=hhv(sa1,16*15);
saB:=llv(sa1,16*15);
saC:=saA-saB;
saD:=ma((sa1-saB)/saC,2)*100;
s底线:=1;
条件1:=cross(sa5,s底线) and sa0-ref(sa0,1)>0 and c>=o;
粉K加仓:IF(条件1,l,h),COLORFF00FF,POINTDOT;
STICKLINE(条件1,h,l,0,1),colorff00ff,linethick2;
STICKLINE(条件1,o,c,4,1),colorff00ff,linethick2;
条件2:=cross(1,sa9) and cross(1,sa5);
白色K抄底:IF(条件2,l,h),COLORWHITE,POINTDOT;
STICKLINE(条件2,h,l,0,1),colorWHITE,linethick2;
STICKLINE(条件2,o,c,4,1),colorWHITE,linethick2;
sxx:=(sa9<1 and sa5<1);
条件3:=cross(1,sa9) and cross(1,sad);
黄色K关注:IF(条件3,l,h),COLORYELLOW,POINTDOT;
STICKLINE(条件3,h,l,0,1),colorYELLOW,linethick2;
STICKLINE(条件3,o,c,4,1),colorYELLOW,linethick2;
syy:=(sa9>97 and sa5>97);
DRAWTEXT(cross(0.5,syy),h+0.04,'●'),color00ff00;
DRAWTEXT(cross(sa9,97) and cross(sa5,97),h+0.15,'●'),color00FF00;
DRAWTEXT(cross(sa9,97) and cross(sad,97),h+0.15,'●'),color00ff00;
Var4:=(LOW+HIGH+CLOSE*2)/4;
aa:= MA(Var4,4),;
压力:HHV(aa,60),colorred;
支:LLV(aa,60),colorffcccc;
v压力:=HHV(aa,10);
vgg:=ma(v压力,3);
vgg3:=ma(v压力,3);
vgg31:=1.25*vgg3-0.25*v压力;
大三叉口环1:if(vgg3>v压力,v压力,vgg31),color00ff00;
vgg33:=2.5*v压力-1.5*vgg3;
大三叉口环2:if(vgg33<v压力,v压力,vgg33),color00ff00;
v支:=LLV(aa,10);
vhh:=ma(v支,3);
vhh2:=ma(v支,3);
vhh31:=1.25*vhh2-0.25*v支;
小三叉口环1:if(vhh31<v支,v支,vhh31),coloryellow;
vhh33:=2.25*v支-1.25*vhh2;
小三叉口环2:if(vhh33>v支,v支,vhh33),coloryellow;
DRAWTEXT_FIX(C>O,0.85,0.001,0,'明阳程序化CXH110.COM'),COLORFF7F00;

明阳程序化 , 版权所有丨如未注明 , 均为原创丨为支持本站发展,也可以支付宝捐赠,谢谢!
转载请注明原文链接:【通达信】大小三叉口环主图指标公式
喜欢 (0)
[明阳程序化]
分享 (0)