• 欢迎访问明阳程序化网,通达信指标公式讲解、公式编写、形态选股、策略预警等。永久网址cxh110.com明阳程序化

通达信基础浮动盈利副图指标公式

转载公式 admin 2年前 (2017-12-22) 已收录
文章目录[隐藏]

通达信基础浮动盈利副图指标公式


公式源码:

EE:=DMA((O+C)/2,V/CAPITAL),LINETHICK2,COLORBLUE;
AA:=BARSLAST(EE>REF(EE,1));{寻找上一次EE大于EE前一天到现在的周期}
BB:=HHV(EE,AA);{取周期内EE的最大值}
CC:=LN(CLOSE/BB)/LN(1.1);{取指数的值,几个板}
DD:=BARSLAST(EE<REF(EE,1));
FF:=LLV(EE,DD);
GG:=LN(CLOSE/FF)/LN(1.1);
HH:IF(EE-REF(EE,1)<0,CC,GG);{基础浮动盈利数据返回值,几个板}
STICKLINE(HH>0,0,HH,3,1),COLORRED;
STICKLINE(HH<0,0,HH,3,0),COLORBLUE;
DRAWTEXT_FIX(C>O,0.85,0.001,0,'明阳程序化CXH110.COM'),COLORFF7F00;{明阳程序化CXH110.COM}

公式翻译:

1. EE赋值:以成交量(手)/当前流通股本(手)为权重(开盘价+收盘价)/2的动态移动平均,线宽为2,画蓝色

2. AA赋值:上次EE>1日前的EE距今天数

3. BB赋值:AA日内EE的最高值

4. CC赋值:收盘价/BB的自然对数/1.1的自然对数

5. DD赋值:上次EE<1日前的EE距今天数

6. FF赋值:DD日内EE的最低值

7. GG赋值:收盘价/FF的自然对数/1.1的自然对数

8. 输出HH:如果EE-1日前的EE<0,返回CC,否则返回GG

9. 当满足条件HH>0时,在0和HH位置之间画柱状线,宽度为3,1不为0则画空心柱.,画红色

10. 当满足条件HH<0时,在0和HH位置之间画柱状线,宽度为3,0不为0则画空心柱.,画蓝色

11. 当满足条件收阳线时,在横轴0.85纵轴0.001位置书写文字,COLORFF7F00

 


公式下载:


文件下载

  公式全称:通达信基础浮动盈利副图指标公式
  下载声明:本站文件大部分属于原创编辑,仅供学习和研究,不得用于商业用途,如有版权问题,请联系明阳!
  下载地址: 百度云下载

明阳程序化 , 版权所有丨如未注明 , 均为原创丨为支持本站发展,也可以支付宝捐赠,谢谢!
转载请注明原文链接:通达信基础浮动盈利副图指标公式
喜欢 (0)
[明阳程序化]
分享 (0)