• 欢迎访问明阳程序化网,通达信指标公式讲解、公式编写、形态选股、策略预警等。永久网址cxh110.com明阳程序化

金叉与死叉选股公式详解

形态选股 admin 1年前 (2017-11-18) 已收录 0个评论
文章目录[隐藏]

金叉与死叉选股公式详解


一、金叉

金叉,又名黄金交叉。金叉是当市场环境逐渐走好,5天均线率先走好转势向上依次上穿10天和20天均线,同时10天均线也在5天均线的持续带动下上穿20天均线形成的。如上图所示,由5/10/20三条均线互相交叉出现形成明显的“黄金三角”,亦称金叉。

金叉并且三线发散是一种强烈看多的信号,下面教你怎么写金叉发散的选股公式。

MA5:=MA(C,5);{5天均线}
MA10:=MA(C,10);{10天均线}
MA20:=MA(C,20);{20天均线}
A1:=MA5>REF(MA5,1);{5天均线向上}
A2:=MA10>REF(MA10,1);{10天均线向上}
A3:=MA20>REF(MA20,1);{20天均线向上}
A4:=CROSS(MA10,MA20);{10天均线上穿20天均线}
A1 AND A2 AND A3 AND A4;{全部条件满足}

二、死叉

死叉,又名死亡三角。死叉是当市场环境逐渐走坏,5天均线率先掉头向下一次跌破10天和20天均线,同时10天均线也在5天均线的持续带动下跌破20天均线形成。和金叉刚好相反,死叉属于一种强烈看空的信号。

死叉发散选股公式如下:

MA5:=MA(C,5);{5天均线}
MA10:=MA(C,10);{10天均线}
MA20:=MA(C,20);{20天均线}
A1:=MA5<REF(MA5,1);{5天均线向下}
A2:=MA10<REF(MA10,1);{10天均线向下}
A3:=MA20<REF(MA20,1);{20天均线向下}
A4:=CROSS(MA10,MA20);{10天均线下穿20天均线}
A1 AND A2 AND A3 AND A4;{全部条件满足}

注:5天均线上穿(下穿)10天均线,5天均线大于(小于)10天均线这些条件没必要再写进去。


明阳程序化 , 版权所有丨如未注明 , 均为原创丨为支持本站发展,也可以支付宝捐赠,谢谢!
转载请注明原文链接:金叉与死叉选股公式详解
喜欢 (1)
[明阳程序化]
分享 (0)

您必须 登录 才能发表评论!